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Course Overview 

In this course you will learn to use the UP Portal to download student information 

from PeopleSoft and also how to use Microsoft Office Excel 2010 as a powerful 

spreadsheet program to process student marks. 

Prerequisites  

 Microsoft Windows  

 Microsoft Excel Basic 

 PeopleSoft User ID and Password 

Course Objectives 

After completing this course you should be able to: 
 

 Download student information via the UP Portal from PeopleSoft 

 Open the data in a spreadsheet 

 Select, insert, delete, copy, move, hide or unhide cells, rows or columns 

 Apply formula and functions 

 Sort lists and create filters 

 Print worksheets 

 Copy data to Grade Roster 

 

 
 

 



DEPARTMENT OF INFORMATION TECHNOLOGY SERVICES 

Processing Student Marks EC Nagel 

 

 

ITS1324 1.02 April 2010 Page 5 of 26 
DEPARTMENT OF INFORMATION TECHNOLOGY SERVICES 

Processing of  Student Marks (Not clickUp) 

The one thing all lecturers have in common is the processing of marks.  The 

processing of marks includes the following: 

 

 Processing of test marks to be able to calculate the year or semester marks. 

 Processing examination marks to be able to calculate final marks. 

 

Lecturers at the University of Pretoria will in future have another option available to 

them to supply the Faculty Administration with marks.  At present the following 

options are being used: 

 Faculty and Student Services Centre.  The PeopleSoft Faculty Centre 

provides access to Class Roster (old class lists) and student information for 

lecturing staff (Lecturers Online- LOL). 

 Faculty Centre (LOL) – View Class lists.  The PeopleSoft Student Services 

Centre system facilitates the management of student and academic processes - 

student recruitment, applications, student records, financial aid, student 

financials (fees), alumni, fund raising, residences, 

 The Paper System is no longer in use. 

Microsoft Internet Explorer  

Microsoft Internet Explorer is a Windows based World Wide Web browser; which 

enable users to display multimedia information, send and receive electronic mail 

and to participate in discussion groups.   

Activate the UP Portal 

 On the Windows Desktop, double click on Microsoft Internet Explorer. 

 The Welcome to UP Portal screen will appear on the screen.   
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 Click in the Username field and enter your personnel email username (mx1). 

 Click in the Password field and enter your email password (mx1).  

 Click on the Login button. 

 The UP Personnel Portal main screen will appear: 

 

 
 

 Click on the plus next to Faculty and Student Services Centre heading. 

 The following information will appear: 
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 Click on the hyperlink Faculty Centre (LOL) – View class lists to view and 

download a class list. 

 The following screen will appear: 

 

 
 

 Click on the Add Course hyperlink to add a course. 

 The Add New Course screen will appear: 

 

 
 

 Enter the Subject Area. 

 Enter the Catalog Nbr (123). 

 Click the Ok button. 

 The following screen will appear: 
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 Under Class List, click on the Download button  to display the class list. 

 The following screen will appear: 

 

 
 

 Click on the Download button  to download the class list. 

 It is possible that the following message will display in Internet Explorer. 
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 Click with the left mouse button on the message and then click on Download 

File. 

 The following screen will appear: 

 

 
 

 Click on the Open button to open the information in Microsoft Excel 2010. 

 Click on the Save button to save the information on your personal computer.  

Activate Microsoft Excel 2010 

 On the Windows Desktop, click on Start  All Programs  Microsoft  

Microsoft Excel 2010. 

 A new blank workbook will appear on the screen: 

 

 



DEPARTMENT OF INFORMATION TECHNOLOGY SERVICES 

Processing Student Marks EC Nagel 

 

 

ITS1324 1.02 April 2010 Page 10 of 26 
DEPARTMENT OF INFORMATION TECHNOLOGY SERVICES 

Open Downloaded File  

 Click on the File tab and then click on Open. 

 Select the file that you saved and click on the Open button. 

 The following message will be displayed: 

 

 
 

 Click on the Yes button to open the file. 

 The file information will be displayed in Microsoft Excel. 

 

 

Insert Columns/Rows 

 Click on column heading B to select column B.   

 A column will be inserted to the left-hand side of the selected column. 

 On the Ribbon, click the Home tab and in the Cells group, click on the 

dropdown arrow of the Insert button. 

 Click on Insert Sheet Columns. 

 A blank column will appear in front of the selected column. 

 Insert one blank column.   

 Enter Mainframe ID as the heading for this column. 

 Copy the Click_UP/Umfundi Ref number to the new column.   



DEPARTMENT OF INFORMATION TECHNOLOGY SERVICES 

Processing Student Marks EC Nagel 

 

 

ITS1324 1.02 April 2010 Page 11 of 26 
DEPARTMENT OF INFORMATION TECHNOLOGY SERVICES 

 Highlight the new column with the heading Mainframe ID.  It is important to 

highlight this column. 

 After copying the number do a Find and Replace to omit the “s”.  On the 

Ribbon, click on the Home tab and in the Editing group, click on the drop down 

arrow of the Find & Select button.   

 Click on the Replace option. 

 The Find and Replace dialog will appear: 

 

 
 

 In the Find what box, enter s. 

 Leave the Replace with box blank. 

 Click on Replace All. 

 Click on the Close button to close the Find and Replace dialog. 

 Move the column Class Section to column F (after the title).  Highlight column F 

– E-mail Address.  Click with the right-mouse button on column F and from the 

pop-up menu click on Insert.  A new blank column will be inserted to the left of 

the E-mail Address. 

 Highlight column M- Class Section.  On the Ribbon, click on the Home tab and 

in the Clipboard group, click on the Cut button. 

 Select the new blank column F and click on the Paste button. 

 Click with right mouse button on column M and click on Delete to delete the 

column. 

 Highlight columns G and H, I, J and K.  This allows you to insert five blank 

columns for marks.  Click with the right mouse button on the highlighted columns 

and click on Insert to insert there blanks columns (test marks, year mark, exam 

mark and final mark). 

 The number of columns to be inserted will depend on the number of test marks 

to be entered. 

 Click in cell G1 and type in Test 1. 

 Click in cell H1 and type in Test 2. 

 Click in cell I1 and type in Year Grade. 
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 Click in cell J1 and type Exam Grade. 

 Click in cell K1 and type Final Grade. 

 70% of Test will be used to calculate the year mark. 

 30% of Test 2 will be used to calculate the year mark. 

 The test marks can now be entered in the inserted columns. 

 Enter the test marks for Test 1, Test 2. 

 After the test marks have been entered, the year mark can be calculated.   

 Position the cursor in cell I2 (Year Grade) and type the following formula:  

=round(((G2*70%)+(H2*30%)),0).   

 Press the Enter key. 

 The year mark will be added. 

 Click on the year mark in cell I2. 

 Click and drag the Fill handle to copy the formula to calculate the year mark for 

all the students on the list. 

 

 
 

 Highlight columns J and K.  Click with the right mouse button on the highlighted 

columns and Insert two blank columns to the left of column K. 

 Type Exam Paper 1 and Exam Paper 2 as the headings. 

 The exam marks for the different question papers can now be entered. 

 Enter the exam marks for Question Paper 1 and Question Paper 2. 

 

 
 

 60% of the Exam 1 mark will be used to calculate the exam mark. 

 40% of the Exam 2 mark will be used to calculate the exam mark. 

 Position the cursor in cell L2 and type the following formula:  

=round(((J2*60%)+(K2*40%)),0). 

 Click on the exam grade in cell L2. 

 Click and drag the Fill handle to copy the formula to calculate the exam mark for 

all the students on the list. 

Fill Handle 
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 After the exam marks have been calculated, the final mark can be calculated.   

 Position the cursor in cell M2 and type the following formula:  

=round(((I2+L2)/2),0).   

 The year and examination grades will be added and then divided by two (2) to 

obtain the final mark.  

 Select all the numbers on the worksheet.   

 On the Ribbon click the Home tab and in the Number group click the dropdown 

arrow in the corner to open the Format Cells dialog. 

 In the Category list, click on Number and change the Decimal Places to 0 to 

display all the marks without any decimals. 

 Instead of changing the numbers in the worksheet to a Number format without 

Decimal Places, it is advised to rather use the ROUND function when working 

out the Jaarpunt (Year Grade), Eksamen (Exam Grade) and Finale Punt (Final 

Grade). 

 The ROUND function is more accurate. 

Sort Lists 

Students who obtained between 45% and 49% as the final mark can be allowed to 

write supplementary examinations.  In order to identify these students, the 

spreadsheet must be sorted from the lowest mark to the highest FINAL MARK.   

 
The sort command arranges rows in a list according to the contents of particular 

columns.   

 

 Select the range to be sorted.  Click on cell A1 and then press Ctrl + Shift + 

End to select the dataset. 

 On the Ribbon, click the Home tab and in the Editing group click the Sort & 

Filter button. 

 Click the Custom Sort option. 

 The Sort dialog appears: 
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 Select the tick box My data has headers. 

 Deselect this box if you did not select the header row.  

 In the first Sort by box, click the down arrow and select Final to sort according 

to the Final mark.   

 Select the option A to Z in the Order box to sort from the lowest to the highest 

mark. 

 Select the option Z to A to sort from the highest mark to the lowest mark. 

 Click on Ok. 

Filter Data 

Students who obtained between 45% and 49% as the final mark can be allowed to 

write supplementary examinations.   

 

Filtering is a quick and easy way to find and work with a subset of data in a list.  A 

filtered list displays only the rows that meet the criteria specified for a column.   

 

 Select a cell in the list to be filtered.   

 Click on cell M2. 

 On the Ribbon, click the Home tab and in the Editing group click the Sort & 

Filter button. 

 Click the Filter option. 

 Drop-down controls will be displayed next to each field name. 

 Click the arrow in the column that contains the data to be displayed, column M 

(Final mark). 

 Select Number Filters  Custom Filters. 

 The Custom AutoFilter dialog appears: 
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 Click the down arrow in the first box and click on the option greater than or 

equal to. 

 Type the number 40 in the box to the right-hand side of the first box. 

 Click the down arrow in the second box and click on the option less than or 

equal to. 

 Type the number 49 in the box to the right-hand side of the second box. 

 Click on Ok. 

 A list with only the student with a final mark between 40% and 49% will be 

displayed. 

 Highlight column N and Insert a column to the left. 

 Name the column Comments. 

 In the remarks column Comments (column N) next to the names of the students 

with a final mark between 45% and 49%, enter the code 999. 

 On the Ribbon, click the Home tab and in the Editing group click the Sort & 

Filter button. 

 Click the Clear option. 

 On the Ribbon, click the Home tab and in the Editing group click the Sort & 

Filter button. 

 Click the Filter option. 

 Students who were absent from the examination receive the code 987 in the 

examination column as well as in the final mark column.  

 Students, who do not appear on any list, can be entered in all the columns. 

 The code 994 in the remarks column indicates that the student must still sit for a 

special examination. 

 Only the codes 999 or 994 are valid in the Comments column. 

Save file in Microsoft Excel Format 

It is useful to save the file for own reference in Microsoft Excel format on your 

computer’s hard disk drive.   

 

 On the Ribbon, click on the File tab and then click on Save or Save As. 

 The Save As dialog appears: 
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 On the left-hand side of the screen, click on the Documents folder to save the 

file in any of your personal folders. 

 The filename can contain the subject code AAL110.   

 In the Save as type box, select Excel Workbook and click on the Save button. 

 A printout can be made for final revision. 

 Click the File tab and then click on Print. 

 The Print dialog will appear. 

 Click on Ok to print the active worksheet. 

Grade Roster 

Before the examination the Faculty Admin Staff will send the Grade roster to the 

departmental secretaries or lecturers to complete. 

 

It is important for secretaries or lecturers to copy only the columns from their 

working Excel spreadsheet to the columns listed on the Grade Roster.  They are 

also not allowed to copy data with formulas. 

 

 Open you working Excel spreadsheet. 

 Select the columns with the formula. 

 On the Ribbon click the Home tab and in the Clipboard group click the Copy 

button. 

 A running border will appear around the selected columns. 

 On the Ribbon click the Home tab and in the Clipboard group click the 

dropdown arrow of the Paste button and select Paste Special. 
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 The Paste Special dialog appears: 

 

 
 

 Click the Values option to paste the formulae as values. 

 Do this for columns I, L and M (Year Grade, Exam Grade and Final Grade). 

 Delete columns G, K, J and K. 

 Only the columns with the Year Grade, Exam Grade, Final Grade and 

Comments must be displayed. 

 Click on cell A2 (do not include the headings). 

 Hold down the Shift key and click on the last cell to be copied H96. 

 On the Ribbon, click on the Home tab and in the Clipboard group, click the 

Copy button. 

 Secretaries and lecturers are not allowed to make any changes to information in 

cell A1 to A15. 

 Open the Grade Roster and click on cell A15.  Click on the Paste button. 

 The data will be copied to the Grade Roster.  

 Errors will be displayed if there is a problem with the EmplID.  The error will be 

displayed when the Grade Roster is uploaded to PeopleSoft. 

Hide/Re-Display Data 

If you want to publish the printed marks, please note that the printed list may not be 

published displaying the names of the students.  The list may only be published 

displaying the student numbers. 

The column with the student names must be hidden.  Hidden columns or rows will 

not print when the worksheet is printed. 
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Hide a Column or Row 

 Click on a column or row heading to select the row or column you wish to hide.   

 Click on the heading for column B. 

 On the Home tab, in the Cells group, click Format.  

 Under Visibility, point to Hide & Unhide, and then click Hide Rows or Hide 

Columns.  

 The hidden row or column will not be visible on the screen. 

Re-display a Row or Column 

 Select two adjacent rows or columns or press Ctrl A on the keyboard to select 

the whole worksheet. 

 On the Home tab, in the Cells group, click Format.  

 Under Visibility, point to Hide & Unhide, and then click Hide Rows or Hide 

Columns.  

Freezing Panes 

When the worksheet becomes larger, not all the data on the worksheet is visible.  

As you scroll through the worksheet to look at different parts of the worksheet, you 

lose the reference points at the beginning of the worksheet.  

 

With Excel, freezing panes means that both the row(s) and columns(s) above and 

to the left of the cell pointer are locked into place and display no matter where you 

scroll in the worksheet.  Position the cell pointer before activating this command as 

the titles will take place to the left, and above from where the cell pointer is. 

 

 To lock rows, select the row below where you want the split to appear.  

 To lock columns, select the column to the right of where you want the split to 

appear.  

 To lock both rows and columns, click the cell below and to the right of where 

you want the split to appear. 

 On the View tab, in the Window group, click Freeze Panes, and then click 

the option that you want.  

 When you freeze panes, the Freeze Panes option changes to Unfreeze 

Panes so that you can unlock frozen rows or columns. 



DEPARTMENT OF INFORMATION TECHNOLOGY SERVICES 

Processing Student Marks EC Nagel 

 

 

ITS1324 1.02 April 2010 Page 19 of 26 
DEPARTMENT OF INFORMATION TECHNOLOGY SERVICES 

Largest Number 

To calculate the three largest scores or marks (out of a certain number of tests) of 

students, the function LARGEST can be used. 

 

 Click on the cell where the answer should be, cell L4. 

 On the Ribbon, click the Formulas tab and click on the Insert Function button. 

 In the Statistical category, choose the Large function. 

 Select the array of numbers, C4:E4. 

 For the largest, choose k=1. 

 For the second largest, choose k=2 (M4). 

 For the third number choose k=3 (N4). 

 Drag the fill handle to copy the formula. 

 

 

Frequency 

Frequency tables can be used to group data.  This function is used to see the 

number of students that obtained a final mark between certain percentages. 

 

 Enter the test marks that need to be grouped.   

 This is called the data-array. 
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 Type the bins-array in a separate column.   

 This is the top number in each group (e.g. 10, 20, 30). 

 

 
 

 Select the column next to the bins-array where the results must be shown. 

 On the Ribbon, click the Formulas tab and click on the Insert Function button. 

 Under the Statistical category click on Frequency. 

 In the data array box, select the data that you want to group. 

 In the bins-array box, select the column indicating how you want to group the 

data. 

 Press Ctrl + Shift + Enter to complete the function. 

 The data can also be represented graphically by creating a line chart. 

Processing of  Student Marks (from clickUP) 

This section of the document aims to help those staff using clickUP, how to prepare 

the final marks to be imported into the PeopleSoft system. 

 

The following steps should be followed: 

 

 Export the class list from the clickUP system. 

 Adapt the Excel spreadsheet to be able to use the data for the People Soft 

system. 

 Merge the data into the People Soft format. 

Export the class list from clickUP 

 In order to do this you have to go to the clickUP course by logging into the UP 

Portal and selecting the clickUP course. 

 Go to the Teach tab. 

 Click on the Grade book link. 

 Ensure that all student data are displayed by: 

 Click on the Grade book Options drop down arrow. 
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 Select the option Show All Members. 

 

 

 

 

 

 

 

 Click on the Export to Spreadsheet button. 

 

 
 

 Select All columns and then click on Export. 

 

 
 

 Save the file to the hard drive of your own personal computer. 
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If you want to see a video on where to click in the clickUP system, you 
can watch this video: 
http://www.click.up.ac.za/flash/captivate/gradebook/export/export_11_demo.htm 

Adapt the Excel spreadsheet  

We now have to change the spreadsheet to prepare the data for People Soft. 
 

 Open the comma-delimited file (.csv) which you have exported from clickUP. 

 Save the file as an Excel file (.xlsx): 

 On the Ribbon, click on the File tab and then click on Save As. 

 Click on Excel Workbook. 

 

 
 

 In order to prepare the spreadsheet, take the following actions: 

 Remove the “s” in front of the student number. 

 Delete the unnecessary columns. 

 Setup the column names. 
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Remove the “s” in front of the student number 

 Insert a new column next to the User id column. 

 

 
 

 Include the following formula in the D column to remove the “s” from the User ID 

field: =RIGHT(C2, LEN(C2)-1). 

 Copy this formula for this column. 

 Insert another column and copy the D column. 

 Paste special the values of the D column into the E column. 

 

 
 

 Now delete columns C and D. 

 Add a heading for column C: EmplID. 

 

 
 

 Delete the Role column. 
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 PeopleSoft is only interested in the Semester mark, Exam mark and Final 

mark.  Therefor ensure that these columns in your Excel spreadsheet are 

values and not formulas.  Repeat the steps explained above to copy and paste 

special values. 

 Delete all the columns accept the Semester mark, Exam mark and Final mark. 

 Note: The semester mark in PeopleSoft is called the Year Grade; the Exam 

mark is called Exam Grade and the Final mark is called Final Grade. 

 Setup columns to be displayed in this order: EmplID, Mainframe ID (same as the 

EmplID), Last Name, Name Initials, Section (ignore), Year Grade, Exam Grade, 

Final Grade. 

 

 
 

 Save the file. 

Merge the data into the People Soft format 

 Open the PeopleSoft Excel file. 
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 Enable the content by selecting the data from the first student number down to 

the last student on the list. 

 You will receive a warning that the Macros have been disabled.  Click on the 

Options button.  The following screen will be displayed: 

 

 
 

 Select the Enable content option and click on Ok. 

 Delete all the data. 

 Copy the data from the clickUP excel list and paste it under the headings. 

 Save. 
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Example of correct Grade book 

 
 
 
 
 
 

The End 
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